summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <contact@amb.tf>2023-01-23 01:51:12 +0100
committerAlexandre Bouvier <contact@amb.tf>2023-01-23 06:23:00 +0100
commit34b1ea9c1925d0da9377973d25e10e9b5ec40e94 (patch)
tree0ada6de7ae81a250258a4243d5bd4d2cc1283aef /externals/CMakeLists.txt
parentMerge pull request #9555 from abouvier/catch2-update (diff)
downloadyuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.tar
yuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.tar.gz
yuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.tar.bz2
yuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.tar.lz
yuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.tar.xz
yuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.tar.zst
yuzu-34b1ea9c1925d0da9377973d25e10e9b5ec40e94.zip
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 94dd8bb62..8532fd7a8 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -158,6 +158,9 @@ if (YUZU_USE_EXTERNAL_VULKAN_HEADERS)
add_subdirectory(Vulkan-Headers EXCLUDE_FROM_ALL)
endif()
-add_library(demangle STATIC)
-target_include_directories(demangle PUBLIC ./demangle)
-target_sources(demangle PRIVATE demangle/ItaniumDemangle.cpp)
+if (NOT TARGET LLVM::Demangle)
+ add_library(demangle STATIC)
+ target_include_directories(demangle PUBLIC ./demangle)
+ target_sources(demangle PRIVATE demangle/ItaniumDemangle.cpp)
+ add_library(LLVM::Demangle ALIAS demangle)
+endif()