summaryrefslogtreecommitdiffstats
path: root/src/web_service/CMakeLists.txt
diff options
context:
space:
mode:
authorFearlessTobi <thm.frey@gmail.com>2022-07-15 19:45:35 +0200
committerFearlessTobi <thm.frey@gmail.com>2022-07-25 21:59:30 +0200
commit6c8e45618578de1406c0bf4a7f976bd4903c339c (patch)
tree25b959db6f30fe75bf5c6fa667ed92af71117986 /src/web_service/CMakeLists.txt
parentFix compilation on linux gcc (diff)
downloadyuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.tar
yuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.tar.gz
yuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.tar.bz2
yuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.tar.lz
yuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.tar.xz
yuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.tar.zst
yuzu-6c8e45618578de1406c0bf4a7f976bd4903c339c.zip
Diffstat (limited to 'src/web_service/CMakeLists.txt')
-rw-r--r--src/web_service/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/web_service/CMakeLists.txt b/src/web_service/CMakeLists.txt
index aff81f26d..753fb6e7a 100644
--- a/src/web_service/CMakeLists.txt
+++ b/src/web_service/CMakeLists.txt
@@ -5,10 +5,12 @@ add_library(web_service STATIC
telemetry_json.h
verify_login.cpp
verify_login.h
+ verify_user_jwt.cpp
+ verify_user_jwt.h
web_backend.cpp
web_backend.h
web_result.h
)
create_target_directory_groups(web_service)
-target_link_libraries(web_service PRIVATE common network nlohmann_json::nlohmann_json httplib)
+target_link_libraries(web_service PRIVATE common network nlohmann_json::nlohmann_json httplib cpp-jwt)